Start a new topic

Update required after update

Hi, After the last update I cannot start the game cause it requests an update (as said the game has been updated to the last version). Also, raid refresh cost is ridiculous. If the average enemy was my strength that wouldn’t be a problem, but 95% of the time I get opponents 20-30% stronger than me. Thanks. D.
Login or Signup to post a comment